Side X Side World Forums banner
1 - 16 of 16 Posts

·
SSW Support Staff
Joined
·
349 Posts
Discussion Starter · #1 ·
Yesterday I took the day off work to ride and it was horrible. I was about an HR into the ride when my transmission started acting funny. When it first happened, I couldnt get the RZR into Low gear or Park, everything else worked. So i rode back to the truck in high gear. Once I got back to the truck, I got the rzr into park very easily, but once it went into park I lost high and low gear. Throughout this whole process reverse was the only gear that was consistent.

You guys have any ideas on whar could cause this? How hard is it going to be to fix it and how much is it going to be?

Thanks AJ
 

·
SSW Director
Joined
·
5,457 Posts
AJ, something to read through and consider - let us know what you come up with.

http://www.prcforum.com/viewtopic.php?t=33035&highlight=shift+linkage
http://www.prcforum.com/viewtopic.php?t=30782&highlight=shift+linkage
 

·
SSW Support Staff
Joined
·
349 Posts
Discussion Starter · #4 ·
Thanks for the info guys. I will look through those links when I get home from work, my work has the other site blocked with a filter.

I hope its a easy fix, we have our 2 week long ride in WV in 2 weeks.
 

·
SSW Director
Joined
·
5,457 Posts
Doug makes a valid point also - hopefully it's just the adjustment that's needed - keep us posted bud !! :wink:
 

·
Registered
Joined
·
103 Posts
Aj when that happened to 2010 it was a broken spap ring inside the trans. Mine was under warrenty,but they had to r+r the engine and trans.
 

·
Registered
Joined
·
25 Posts
leimy said:
Aj when that happened to 2010 it was a broken spap ring inside the trans. Mine was under warrenty,but they had to r+r the engine and trans.
Okay, what does R+R stand for?
Remove and Repair
Remove and Replace
 

·
SSW Support Staff
Joined
·
349 Posts
Discussion Starter · #8 ·
I am taking it to the dealership tomorrow hopefully they don't rape me on it!!!! If they do, I'm gonna put it up for sale and put the money towards a new rzr s.

I'm guessing r and r stands for remove and repair!
 

·
Registered
Joined
·
103 Posts
remove and repair. It took 5 weeks to get parts. I looked up the parts mine needed and they aren't cheep.
 

·
SSW Support Staff
Joined
·
349 Posts
Discussion Starter · #10 ·
I really hope it doesnt take 5 weeks to get parts to fix this. I will be really upset!!!
 

·
SSW Support Staff
Joined
·
349 Posts
Discussion Starter · #11 ·
Well i got my RZR back today agter all the transmission problems. The dealership found the main gear assembly to be bad. The low gear gear was spinning inside the high gear. Anyways the part was 280 bucks but the labor was 650. Kinda sucked!!!!! lol

But on a side note, I will be ready for my WV trip friday with hopefully no more malfunctions.!!!
 

·
SSW Director
Joined
·
5,457 Posts
Mrwizardd83 said:
Well i got my RZR back today agter all the transmission problems. The dealership found the main gear assembly to be bad. The low gear gear was spinning inside the high gear. Anyways the part was 280 bucks but the labor was 650. Kinda sucked!!!!! lol

But on a side note, I will be ready for my WV trip friday with hopefully no more malfunctions.!!!
AJ, sorry to hear of your tranny misfortunes but glad to hear it's back up and running and you'll be able to make your W.Va. trip !! When you return let us know how it went and post some pics for us also. Enjoy and be safe out there !!
 

·
SSW Support Staff
Joined
·
349 Posts
Discussion Starter · #13 ·
Thanks Rich, I will make sure I get some good pics this time. Most of the time I am to busy getting muddy to worry about taking pics!!!
 

·
Registered
Joined
·
103 Posts
Glad to hear your's didn't take 5 weeks to fix.
 

·
SSW Support Staff
Joined
·
1,819 Posts
Glad you got your machine back up before the ride, WV is always a great place to ride.
 
1 - 16 of 16 Posts
Top